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Introduction

Turbo Pascal (With DOSBox) (TPWDB) is a free and open source compiler and

Integrated Development Environment (IDE) for Pascal language on Windows 64 Bit and

32 Bit. Using basic Pascal programming, many functions, no need to install multiple

steps and integrate some other tools.

· Features of Turbo Pascal (With DOSBox)

Runs on Windows 32/64 Bit Thanks to DOSBox

No need to install multiple steps. Easy to use

​Add​tool​clear/refresh​screen​DOS​(Shift​+​F3)

Run and access it all in one place with the Programming Center

Write Vietnamese easily in Turbo Pascal with TCVN library and Vietnamese
writing mode.

Thank you for using our Turbo Pascal (With DOSBox) 

This​userʼs​manual​is​designed​to​be​a​reference​tool​for​operation​of​your​system.​Here

you can find detailed operation information about Turbo Pascal (With DOSBox).

§ View License here (Including Third-Party License Agreement and License

Agreement here)

Also can be viewed by going to Programming Center of Turbo Pascal (With DOSBox)

and into tab About, clicking on License or read the License.txt file that can be accessed

from the directory path C:\TPWDB\Main\

§ Information about the release history, short information of the software can be

viewed at the Readme.txt file in the path C:\TPWDB\Main\ (Can be accessed from

Tab About in Programming Center)

§ Download the latest software releases at https://turbopascal-wdb.sourceforge.io

§ Copyright © 2017-2020. Lưu​Nguyễn​Thiện​Hậu.

Turbo Pascal (With DOSBox) is free and open-source under MIT License. Project is

hosted at Sourceforge.

Website: https://turbopascal-wdb.sourceforge.io

 

Basic Infomations

This section includes an overview of basic information about Turbo Pascal (With

DOSBox), including the following items:

https://sourceforge.net/p/turbopascal-wdb
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· System Requirements
· Getting help
· License
· View Version and Documents
· Shortcut

 

System Requirements

These are the basic requirements for installing Turbo Pascal (With DOSBox).

Items Requirements

Windows

Version
Windows XP SP3/7/8/8.1/10 (All In 32 and 64 bit Version)

Windows Server (2003 or higher)

RAM 128 MB or Higher

Capacity 20 MB in Hard drive

 

Getting help

· You can download other user manual at Turbo Pascal's homepage (With DOSBox)

at: https://turbopascal-wdb.sourceforge.io/doku.php/support

· However, if you have the software installed from version 7.3.4 onwards, there will

be a User's Guide available when installing the software by accessing the User

Manual Section in the Start Menu.

· The manual of the software can also be accessed here through the User Manual

button in the Options and About interface.

· For more help, see section More Help for details

 

License

Turbo Pascal (With DOSBox) License Agreement
 Copyright (C) 2017-2020. Lưu​Nguyễn​Thiện​Hậu

Turbo Pascal (With DOSBox) is free and open-source. 
You can freely use Turbo Pascal (With DOSBox) under the terms of MIT License.

​About​the​MIT​License

​Copyright​2017-2020​Lưu​Nguyễn​Thiện​Hậu

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the "Software"), to deal in the Software

http://turbopascaldb.dx.am/support
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without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

Third-Party License Agreement

This software uses other 3rd party software based on the specified licenses
(including open source licenses) that the author offers.

Turbo Pascal 7.0 license:

Turbo Pascal 7.0
Copyrights (C) 1983,92 Borland international

VietRes (Vietnamese Resident for DOS) License Agreement:

VietRes (Vietnamese Resident for DOS) 2.5A 
Copyright © 1992-95. Seatic, VietRes. All Rights Reserved

TCVN library for Turbo Pascal License Agreement:

TCVN library for Turbo Pascal
Copyright​©​Nguyễn​Công​Hoàng

DOSBox 0.74-3 License Agreement:

DOSBox version 0.74-3
Copyright © 2002-2019 DOSBox Team, published under GNU GPL

 

View Version and Documents

You can view the version by visiting Readme file in the Start Menu Access

The text in the software can be viewed by going to Tab About in Programming Center

of Turbo Pascal (With DOSBox)



Turbo Pascal (With DOSBox) User Manual

6 / 34
Copyright © 2017-2020 by Lưu Nguyễn Thiện Hậu. All Rights Reserved.

See Introduction and Shortcuts for details.
 

Shortcut

 Information about the shortcuts in the software is in the table below.

Name Location Describe

Turbo Pascal (With
DOSBox)

Desktop &
Program Menu

Start Turbo Pascal (With DOSBox)

Website Program
Menu 

Visit Website

Turbo Pascal (With
DOSBox) Help

Program
Menu 

View Help and User Manual

Readme Program
Menu 

Short info about software and
software version.

Vietnamese Help -
TPWDB

Program
Menu 

View Help and User Manual
(Vietnamese)

Uninstall Program
Menu 

Uninstall Turbo Pascal (With DOSBox)

Programming Center -

Turbo Pascal (With

DOSBox)

Desktop &
Program Menu

Programming Center of Turbo Pascal

(With DOSBox)

 

Interface

This section includes introduction of the general interface in Turbo Pascal, including the

following sections:

· Main Interface

· Menu bar

· Programming Center

 

Main Interface
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1. Menu bar : Where to store tasks to work on Turbo Pascal, see section .... for

detailed description.

2. Window Command line Programming: Where to edit and work Pascal programming

commands in pas or inc files.

· See more items for details: Make and run my Program and Sample in Pascal

3. Name file : Where to show pas file name. The format may be <file name> .pas or

NONAMExx.pas for an unsaved or newly created file (xx is the number of the newly

created file).

· See more items for details: New File Open file and Save file

4. Staus and most command bar: Where quick command buttons are at work, the red text to

the left of each command button name is the shortcut of the command button. See

section Menu bar for details.

 

Menu bar

The menu bar gives you access to all the features of Advanced Installer. It contains the

following sub menus: “File”, “Edit”, “Search”, “Run”, “Compile”,"Debug", "Tools,

“Options”,"Window" and “Help”. 

The File bar
File management includes commands:
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· Create a new file

· Save and open the file

· change the default save path

· go to the DOS interface

· Exit Turbo Pascal

The Edit Bar
Execute commands related to text and code such as Copy, cut, paste, delete text,

paragraphs, code and view clipboard

· See more items for details: Tools for programming

The Search Bar
Execute commands related to finding and replacing paragraphs and code snippets, in

addition to finding and missing Pascal programming errors.

· See more items for details: Tools for programming

The Run Bar

Perform pascal file commands and related commands.

· See more items for details: 

Run and Complie

Error in Pascal

The Compile Bar
Execute commands related to pascal file execution.

· See more items for details: 

Run and Complie

Error in Pascal

The Debug Bar
Execute commands related to Debug pascal, in addition to view the DOS interface when

compiling and running pascal files, see the current state of the DOS interface.

The Tools bar
Open the notification window and run the built-in tools, including the Clear and Refresh
DOS Scrren tool.

The Options Bar 
Set up and customize Turbo Pascal
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The Window Bar
Perform custom related commands, manage windows, arrange windows in Turbo

Pascal

· See more items for details: 

Window manage

The Help Bar
Implement help using Turbo Pascal
· See more items for details: 

More Help

 

Programming Center

Since version 7.3.4. All startup, custom and access modes for Turbo Pascal and
DOSBox related documents will be included in the "Programming Center".
To get started, visit the "Programming Center" in the list of all applications in the Start
Menu (You can search for this application with the keyword "Programming Center"). A
dialog box appears as shown below. See also Edit DOSBox Conf file for more DOSBox
configuration functions.
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Quick Start Guide

This section includes a very basic user guide for Turbo Pascal beginners, including:

· Open Turbo Pascal (With DOSBox)

· Make and run my Program

For other uses, see More Help for details

 

Open Turbo Pascal (With DOSBox)
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To launch the software, open the Turbo Pascal icon (With DOSBox) on the

desktop, or go to Start> All Apps> Turbo Pascal (With DOSBox) > Turbo Pascal (With

DOSBox) or Open File Explorer to open the software

See more items for details: 

Shortcut

View Version and Documents

 

Make and run my Program

First to create and run the software, create a new file by going to File> New ...

Programming in Pascal code, if you don't know Pascal programming, see this example

to know in the section Sample in Pascal

When programming the Pascal file, compile the file into Compile> Compile (or press
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ALT + F9).  If successful, the following dialog box will appear.

When programming the Pascal file, to run the file, go to Run> Run (or press F9). If

successful, the program will run.

NOTE: in the process of compiling or running the program, if there is an error (the

compiler has an error that will not show the above dialog box), an error will be

reported , see section Error in Pascal for details.

 

Use Turbo Pascal

This section includes Turbo Pascal's basic usage instructions, including the following
sections:
· Notes When Using Software
· New File
· Open file
· Save file
· Change Dir
· Tools for programming
· Run and Complie
· Error in Pascal
· Clear and Refresh DOS Scrren
· Window manage
· Use other functions
· Exit Turbo Pascal
· Sample in Pascal
· Note When using a unikey with Turbo Pascal (With DOSBox)
· Keyboard shortcut
For other uses, see More Help for details.

 

Notes When Using Software

Here are some things to keep in mind when using software:

· To Compile file Pascal, Please Save File Before Use Command
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(Note: Will not Compile or run File Pascal if In Programmer File Has Programming

Error, See Error In Pascal to see what the error is.)

· To Run file Pascal, Please Save File Before Use Command

(Note: Will not Compile or run File Pascal if In Programmer File Has Programming

Error, See Error In Pascal to see what the error is.)

· Do not close the window By clicking the X on the left corner of the

window you have to

go to File> Exit, if not, you can lose the file you are working on if you have

not already.

·  Do not click away from the software window if you are running the

program,

including using the key combination to switch the Alt + Tab window,

otherwise you will not be able to click on the menu bars and other

components in Turbo Pascal.

· If you get a typo in Turbo Pascal (With DOSBox), turn off the typing

support in your computer.
 

New File

To create a new File in Turbo Pascal (With DOSBox), boot into Turbo Pascal (With
DOSBox). By default a file named Welcome.txt is available on the screen for notify note
when using the software. To start creating a new file for programming, go to File> New
to create a new file.

 

Open file

If you want to open a file you have made and save it to your computer. Go to File>

Open (or press F3) to enter the open dialog box:
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In the dialog box open, we select the file to open by selecting the file ending in .pas in

the Files file table, then click Open to open.

When we select the file .pas we can see the date and time of file modification, file size

(Byte unit) at the bottom of the file picker (yellow square frame in the picture).

If you want to open the file in other folders, click ...\ to view the parent folder. Click

[Folder Name]\ to open the folder

· Tips:

By default Turbo Pascal only displays the .pas file, if you want to display files other than

.pas, in the Name field, enter *.<File format to display> if you want to show the file

with the specified extension or type *.* if you want to display all file formats.

Also in this field you can enter the path if you want to enter the directory directory

quickly

To quickly open the file, double-click the file to open.

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right

If you open the file by pressing Replace, you will open the selected file and close the file

you are opening, notice if the unsaved file will have a message asking to save the file

before opening the selected file.

Note: There will be some files of the form <file name (incomplete)>~1.pas. These are

file names that exceed 7 characters. Turbo Pascal cannot display the file name correctly

but still open the file normally.
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Save file

Save file on Turbo Pascal 

If you want to save the created file, go to File> Save (you can press F2) to save the file

The file save dialog box appears, enter the file name in the Name field and click OK to

save.

Tip: If you want to reuse the file name, click the file name already in the file list table

and edit the file name and save.

To save in another folder, use the directory operation as in the file open dialog box.

If you want to overwrite the file, click the existing file name and save it, there will be a

message that you want to overwrite the existing file, select overwrite to save.

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right

Note: The file name must be no more than 7 characters (including spaces).

The section below selects the file name that will contain the date and time information

to create the file as shown in the file open dialog box.

If the file has been saved before, when you click the save button, it will save the file

changes, and if you want to save with another name, go to File> Save As ... and save

the same way as above.
 

Change Dir

If you want to change the default save path, go to File> Change Dir ...
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Here we change the default save path by selecting the directory in the Directory tree

(Directory Tree).

You can also enter the path in the Directory Name field

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right

Click the Chdir button to refresh the directory tree

Press the Revert button to bring back the path you changed last.

After changing click OK to save.

Note: To save as the default setting in subsequent runs, go to Options> Save ....
 

Tools for programming

Turbo Pascal (With DOSBox) provides some tool functions in programming, how to use

these tools is guided below.

Cut, Copy and Paste

Turbo Pascal has a way to copy, cut and paste them in Word, but other usage

mechanisms.

· To copy a piece of text, select the original paragraph and click Edit> Copy (or press

Ctrl + Ins).

· To cut a piece of text, select the text to cut and click Edit> Cut (or press Shift +

Del).

· To create a paragraph, select the text you want to cut and click Edit> Paste (or press

Shift + Ins).
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Note: If you paste blank, just do the above, if you want to replace the existing text

override, select the text to overwrite and go to Edit> Delete (Or press Ctrl + Del) then

click Copy or Paste at that location.

In addition, Delete button in Edit also deletes existing text, to delete existing text,

go to Edit> Delete (Or press Ctrl + Del)

Find and Replace

· To Search for a piece of text or code, go to Search> Find ...

The search dialog box appears, I enter the code, the phrase to search in the Text to

Find input field. In addition, you can change the results, filter the search results by

adjusting options in Options, Direction. Scope and Origin (Red frame in the image).

After finishing click OK to find.

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right

· To replace a piece of text or code, go to Search> Find ...

The dialog box appears, I enter the code, the phrase to search in the Text to Find input

field and enter the replacement word in the New Text input field. Alternatively, you can

change the results, filter the search results and replace the search by adjusting the

options in Options, Direction. Scope and Origin (Red frame in the image). After

finishing, click OK to find and replace. If you click Change All will search all the search

terms and replace them all.

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right
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Go to line number

To find a line, go to Search> Go to line number ... and enter the line number in the

Enter New Line Number box and click OK.

You can use the history list to re-enter text that you've already entered, click the arrow

icon to the right

Find Error and go to last error

· To find the error, go to Search> Error Search and enter the error address in the

Error address box and click OK to Search. (You can use the history list to re-enter

text that you've already entered, click the arrow icon to the right).

· Go to last error is command displays the last compile-time error message at the top

of the screen and positions the cursor near where the error occured. No error

message is displayed if the last compilation was successful.

 

Run and Complie

When programming the Pascal file, compile the file into Compile> Compile (or press

ALT + F9).  If successful, the following dialog box will appear.
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When programming the Pascal file, to run the file, go to Run> Run (or press F9). If

successful, the program will run.

If you run the hidden program, you can view the output of the program by opening the

Output window.

See the DOS screen status by going to User Scrren.

If the screen is too messy, you can use the Clean / Refresh DOS Scrren tool to clear the

screen before running, so it will be better

NOTE: in the process of compiling or running the program, if there is an error (the

compiler has an error that will not show the above dialog box), an error will be

reported , see section Error in Pascal for details.

 

Error in Pascal

When programming Pascal When there is a Programming Error or when the program fails,

Turbo Pascal will Report Error As shown below, the error codes and error information are

located below..
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 To Know About Pascal Programming Errors Or Error When Starting File,You can see the

following ways: Go to Help> Error Messages and edit the file to delete the above

programming error so that the file can be compiled.

 



Turbo Pascal (With DOSBox) User Manual

21 / 34
Copyright © 2017-2020 by Lưu Nguyễn Thiện Hậu. All Rights Reserved.

Clear and Refresh DOS Scrren

 Turbo Pascal (With DOSBox) provides an important tool in programming.

It's a Clean / Refresh DOS Screen tool, which clears the text on the Dos screen, making the

screen blank if the screen gets too messy when running Pascal software multiple times.

Before Use Clean / Refresh DOS Screen tool

 After Use Clean / Refresh DOS Screen tool

 To run this tool go to Tools> Clean / Refresh DOS Screen (Shift + F3).
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Window manage

The Window menu contains commands for manipulating and opening windows. Most of

the windows you open from this menu have all the standard window elements, like

scroll bars, a close box, and zoom icons.

Tile, Cascade, Close All, Refresh Display, Size/Move, Zoom, Next, Previous, Close, List

· Choose Window> Tile to tile all your open Edit windows.

· Choose Window> Cascade to stack all open Edit windows.

· The Refresh Display command restores the IDE screen. This is handy if your

program has accidentally overwritten the screen.
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· Choose Zoom to resize the active window to the

maximum size.

If the window is already zoomed, you canchoose this command to restore it to

itsprevious size.

You can also double-click anywhere on thewindow's title bar (except where an

iconappears), or on the Zoom box in the window'supper right corner (2), to zoom or

unzoom the window.

· Choose Next to make the next window active, which makes it the topmost open

window.

· Choose Previous to make the most-recently active window be active again.

· Choose Close to close the active window. You can also close by pressing the key in

the left corner of the window (1).

· The List command opens the Window List dialog box, which lists all the windows

currently open.

· If you press Shift while you use the arrow keys, you can change the size of the

window. When it's at the size you want, press Enter.

If a window has a Resize corner, you can drag that corner to resize the window (3).

· When you choose Window> Size/Move, the active window moves in response to the

arrow keys. Once you've moved the window to where you want it, press Enter. You

can also move a window by dragging its title bar.
 

Use other functions

·  The history list attached to an input box lists whatever text you typed the last few

times you used the dialog box.

You can get to the history list whenever you see a down-arrow icon to the right of an

input box.

You can use the history list to re-enter text that you've already entered. You can also

edit an entry in the history list directly.

Press Esc to exit from the history list without making a selection.

· The commands on the Debug menu control all thefeatures of the integrated
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debugger. You can change default settings for these commands in the Options>

Debugger dialog box.

The Debug Bar
These are the available menu commands:

 Breakpoints, Call stack, Register, Watch, Output, User screen, Evaluate/Modify, Add

Watch, Add Breakpoint

The following is the function of Output and User Scrren (Alt+F5)

Output-View DOS screen when compiling files in a window. Display the current status

that is happening on the DOS screen.

User Scrren (Alt+F5)-View the current status on the DOS screen.
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The Options Bar
· The Options menu contains commands that let you view and change various default

settings in Turbo Pascal. Most of the commands in this menu lead to a dialog box.

Compiler..., Memory sizes..., Linker..., Debugger..., Directories..., Tools, Environment,

Open, Save, Save as

 

Exit Turbo Pascal

To exit Turbo Pascal, go to File> Exit to exit

Note, if there are any unsaved files, it will notify you if it is saved before exiting

It is recommended to use this method to exit Turbo Pascal, do not use the key

combination to exit or click the X corner of the window because it will cause the file to

be saved or changed.

· See more items for details: 

Keyboard shortcut

Notes When Using Software
 

Sample in Pascal

 This is an example of pascal programming
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 Program HelloWorld.Pas

Program HelloWorld;

uses crt;

Begin

Clrscr;

Writeln('Hello World');

Readln;

end

Inside

program Helloworld; : Program Declaration, Helloworld is the name of the Program

Uses Crt; : Library Declaration, Crt Library Name Required

Begin: Begin the command

Clrscr; Clear Screen Commands

Writeln ('Hello World'); : On Screen Display, On Screen Display ('_')

Readln; : stop the screen until the user press enter

End. End the Program

Other Commands

TextBackground (White); screen color change, color name in (_)

TextColor (White); Change screen color, color name in (_)

NOTE: All Commands Must Have; before ending the Or statement before concluding

the program declaration Or library. (Except the Begin command and other commands)
 

Note When using a unikey with Turbo Pascal (With DOSBox)

  Note: These are articles related to Error typing Vietnamese software.

To avoid having the wrong character set when programming Pascal on Turbo Pascal

(With DOSBox) software, turn off Unicode or switch to English mode before

programming.

To switch to English mode, scroll to the right of the taskbar, find the [V] icon and press

to switch to [E]


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To turn off Unikey on the Unikey interface and press the end to turn off Unikey

 

Keyboard shortcut

·  Keyboard shortcuts In DOSBox

Shortcuts Description

CTRL-E Kill (close) DOSBox. (Warning : Please Save File Before Before closing
with this Off key, it is not recommended to use this shortcut key)

ALT-ENTER Switch to full-screen (and back). (Windows XP/Vista/7 Only)

ALT-PAUSE Pause emulation.

· Keyboard Shortcut In Turbo Pascal

Key Action

F3 Open The File Pascal

F2 Save The File Pascal

Alt+X Exit Turbo Pascal

ALT-Backspace (<-) Undo Action

SHIFT-DEL Cut

CTRL-INS Copy

SHIFT-INS Paste

CTRL-DEL Delete

CTRL-F9 Run Programs

F8 Step Over

F7 Trace Into

F4 Go to cursor

ALT+F9 Compile Program

F9 Make

Shift+F2 Grep

Shift+F3 Clear/Refresh Scrren DOs



Turbo Pascal (With DOSBox) User Manual

28 / 34
Copyright © 2017-2020 by Lưu Nguyễn Thiện Hậu. All Rights Reserved.

CTRL-F5 Size/Move Window

F5 Zoom Window

F6 Next Window

SHIFT+F6 Previous Window

ALT+F3 Close Window

ALT+0 List Window

· Shortcuts Other : Ctrl-F3, Alt-F5, Ctrl-F4, Ctrl-F7, .......

· Other DOSBox Shortcuts

Key

Action

ALT-ENTER

Switch to full-screen (and back).

ALT-PAUSE

Pause emulation.

CTRL-F1

Show the keymapper configuration screen,

CTRL-F4

Update cached information about mounted drives. Useful if you changed
something
on a mounted drive outside of DOSBox

. Also cycles through disk images mounted using IMGMOUNT

CTRL-F5

Save a screenshot (goes to capture folder).

CTRL-ALT-F5

Start/Stop recording of AVI video. NOTE: You may well have some problems
with
this, please see Recording Video for more information.

CTRL-F6

Start/Stop recording sound output to a wave file (goes to capture folder).

CTRL-ALT-F7

Start/Stop recording of OPL commands.(not recommended to use this shortcut
key)

CTRL-ALT-F8

Start/Stop the recording of raw MIDI commands.(not recommended to use this
shortcut key)

CTRL-F7

Decreases frameskip.

CTRL-F8

Increases frameskip.
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CTRL-F10

Capture/Release the mouse (if you need to use the mouse within DOSBox).

CTRL-F11

Decrease DOSBox cycles (slows down the emulation).

CTRL-F12

Increase DOSBox cycles (speeds up the emulation)

 

Advanced Use

This section includes Turbo Pascal's high-performance instructions, including the

following sections:

· Modify and Repair

· Directory Structure in Turbo Pascal (With DOSBox)

· Edit DOSBox Conf file

For other uses, see More Help for details.
 

Modify and Repair

This article explains how to modify already installed Turbo Pascal (With DOSBox) using

Turbo Pascal (With DOSBox) Installer. We can repair Turbo Pascal (With DOSBox) using

Turbo Pascal (With DOSBox) Installer. If we missed installing in Turbo Pascal (With

DOSBox) we need not uninstall and again install. We can add directly without

uninstalling only which we have missed by Turbo Pascal (With DOSBox) Installer.

Open Turbo Pascal (With DOSBox) Installer

Choose Add or Remove Programs in Control Panel, select the program in the Add or

Remove Programs dialog box and click the Change button.
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The Turbo Pascal (With DOSBox) Installer will open and then click “Yes”​button, There

are three important options we can see in the installer.

Click the sections below to see the effects and how to use the above

functions:

· Modify

· Repair

· Uninstall

Modify

Modify is used to add extra features in Turbo Pascal (With DOSBox). If we have already

installed Turbo Pascal (With DOSBox) but forgot to install any features, we can use

modify option we add new features. We do not uninstall and again re-install full Turbo

Pascal (With DOSBox).

First, click Modify we can see already installed features are selected. Now, select what

are the new features need to add or remove in Turbo Pascal (With DOSBox). We can see

the

installation size for selected one in right side in Turbo Pascal (With DOSBox) Installer.
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Click Next button. Then click Install to start installing the selected components. We can

see the Installation Progress.

After successful, press Finish to end the process. You can already use the newly added

components.

Repair

 Any problem or corrupted any files in Turbo Pascal (With DOSBox) use repair to

resolve problems.

First, open Turbo Pascal (With DOSBox) Installer and click repair options which

look like below screenshot.
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Then click Repair to start the repair process. The repair will take some minutes to

complete. If need to cancel repair, click Cancel to stop the repair.

After successful, press Finish to end the process.

Uninstall

 We can uninstall Turbo Pascal (With DOSBox) using Turbo Pascal (With DOSBox)

Installer. If no need forTurbo Pascal (With DOSBox) we can uninstall without going

to “Programs and Features” in Control Panel. Open Turbo Pascal (With DOSBox)

Installer and click Remove option.

After click Remove then click Remove to continue to uninstall.

Uninstall will continue after clicking Remove button. Now progress bar will be open

and can see the uninstall percentage.

After successful, press Finish to end the process. You have uninstalled Turbo

Pascal (With DOSBox) successfully, you can reinstall at any time by running the

software's installation file.

 

Edit DOSBox Conf file

You can edit the DOSBox's .conf file using tab "Configuration" in Programming Center.

In the tab "Configuration" section, click "Edit Normal Mode file" of "Edit Vietnamese
Writing Mode file" to start editing the DOSBox .conf file, depends on the mode you want
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to edit. Note that this may change the way DOSBox works. For more information on
how to set up DOSBox, click "DOSBox Configuration Help" or "DOSBox Manual" in tab
Help to learn more.

 

More Help

You can find other software tutorials in the Help Menu in the Turbo Pascal Menu
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Other Infomantion

· If you have any suggestions for any bug fixes please report web site error at

sourceforge.net here: web site error

· You can discuss the software here on page SF.net

· Website: https://turbopascal-wdb.sourceforge.io

 

https://sourceforge.net/p/turbopascal-wdb/tickets/
https://sourceforge.net/p/turbopascal-wdb/discussion/
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